Vulnerabilidad en el manejo de los URI en Windows

Una vulnerabilidad en Microsoft Windows, puede ser explotada por personas maliciosas para comprometer los sistemas vulnerables.

El problema es causado por un error de validación en la entrada de datos cuando se envían ciertos URIs a protocolos registrados (por ejemplo “mailto”, “news”, “nntp”, “snews”, “telnet”, y “http”).

Diversas aplicaciones pueden ser utilizadas como vectores de ataque (por ejemplo Firefox), permitiendo que un atacante remoto pueda ejecutar comandos en el equipo del usuario.

Para que ello ocurra, solo basta que el mismo visite sitios maliciosos o haga clic en enlaces especialmente modificados, conteniendo al final un determinado carácter (%), con ciertas extensiones (por ejemplo .BAT, .CMD, etc.)

Un URI (Uniform Resource Identifier o Identificador Universal de Recursos), es la secuencia de caracteres utilizada para identificar una ubicación, recurso o protocolo accesible en una red. Consta de dos partes, el identificador del método de acceso o protocolo (http:, ftp:, mailto:, etc.), y el nombre del recurso (//dominio, usuario[@]dominio, etc.).

Software vulnerable:

– Microsoft Windows Server 2003 Datacenter Edition
– Microsoft Windows Server 2003 Enterprise Edition
– Microsoft Windows Server 2003 Standard Edition
– Microsoft Windows Server 2003 Web Edition
– Microsoft Windows XP Home Edition
– Microsoft Windows XP Professional

La explotación exitosa de este problema, requiere que Internet Explorer 7 esté instalado en estos sistemas, aunque no sea el navegador por defecto.

Windows Vista no sería vulnerable.

Según informa Secunia, las siguientes aplicaciones han sido identificadas como vectores de ataque en equipos con Windows XP SP2 y Windows Server 2003 SP2 totalmente actualizados:

* Firefox versión 2.0.0.5 y anteriores
* Netscape Navigator version 9.0b2
* mIRC version 6.3
* Adobe Reader/Acrobat version 8.1 y anteriores
* Outlook Express 6
* Outlook 2000

Otras versiones y aplicaciones podrían ser afectadas.

Hasta el momento, Microsoft ha insistido en que esta debilidad no es un problema de su software, sino una característica de diseño. Fabricantes como Mozilla, han actualizado sus productos para que el problema no sea explotado a través de sus propias aplicaciones (por ejemplo, Firefox 2.0.0.6 no es vulnerable).

Otros han alertado a sus usuarios y publicado medidas para minimizar el riesgo (ejemplo: Adobe Acrobat y Acrobat Reader).

Algunos comentarios recientes, parecen indicar que Microsoft reconocería oficialmente que el problema (sea su culpa o no), existe, y que podría ser solucionado con una actualización.

Por el momento, se aconseja precaución a la hora de navegar, no hacer clic en enlaces no solicitados (incluye el correo electrónico recibido), y no abrir archivos PDF no esperados o de fuentes desconocidas.

FUENTE:vsantivirus

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos necesarios están marcados *

Puedes usar las siguientes etiquetas y atributos HTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>